2013年03月02日

Apache2.4系をソースからコンパイルする

aprが別途必要。2.4から分かれたらしい。面倒な…。
CentOS6にはaprが入ってはいるが、1.3.9で、apache2.4は1.4.0以降を要求するので、別に入れてやらねばならない。
PCREも要求されるので入れなければならない。
概ねこんな感じでいける。
wget http://ftp.riken.jp/net/apache//apr/apr-1.4.6.tar.gz
tar xvfz apr-1.4.6.tar.gz
cd apr-1.4.6
./configure
make
make install

wget http://ftp.riken.jp/net/apache//apr/apr-util-1.5.1.tar.gz
tar xvfz apr-util-1.5.1.tar.gz
cd apr-util-1.5.1
./configure --with-apr=/usr/local/apr
make
make install

wget ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.32.tar.gz
tar xvfz pcre-8.32.tar.gz
cd pcre-8.32
./configure
make
make install

wget http://ftp.yz.yamagata-u.ac.jp/pub/network/apache//httpd/httpd-2.4.4.tar.gz
tar xvfz httpd-2.4.4.tar.gz
cd httpd-2.4.4
./configure --with-apr=/usr/local/apr \
--with-apr-util=/usr/local/apr \
--with-pcre=/usr/local
make
make install


posted by usoinfo at 01:05 | Comment(0) | Linux | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

×

この広告は180日以上新しい記事の投稿がないブログに表示されております。